PDS Logo Paragon Development Systems
print page

Oops! Browser Security Issue

In 2016 there will be new industry standards put in place for websites which utilize HTTPS security. PDS will be complying with these new standards and as a result we will require all visitors to be using a modern browser which supports these requirements. We show your current browser is one that will soon be unsupported and strongly recommend you upgrade to one from the list below.

  • • Firefox 27 and newer
  • • Chrome 22 and newer
  • • Android 5.0 and newer
  • • Safari 9 and newer
  • • Windows 7 and newer with IE 11 and newer (IE 8-11 with TLS 1.1 activated)

We apologize for any inconvenience this may have caused. For more information on this industry-wide change, please visit: